Pentax K-x memory card problem: solution update

I’ve long since fixed the memory card problem I was having five months ago with my new Pentax K-x, but I just realized I hadn’t updated the saga on here.

I left it in Part 2 with a possible solution and a new approach to memory card management. It’s been working fine since updating the firmware and formatting the card in-camera a few times. Since then I’ve relaxed my proposed approach without any problems. Specifically:

  • I have plugged the SD card directly into my computer’s card reader for importing, and this has not been a problem;
  • I have deleted individual photos in-camera without problems;
  • I have deleted all photos in-camera through the “Delete All Photos” menu option without problems.

So, really, it looks like it was a firmware update that did it. Update the firmware in your cameras, kids. And format your memory cards in-camera before using them.

I’ve taken thousands of photos on that card since fixing the problem, so it’s definitely working as it should.

Welcome back, Pentax

I recently purchased my entrance ticket into the world of digital photography, in the form of a Pentax K-x.

It had been nearly five years since I last owned a working camera, that being an Asahi Pentax that my dad was nice enough to let me co-opt in the late 90’s. ┬áHe had owned this camera since he bought it new in the mid 60’s, and it finally wore out around five years ago.

In my glory years with the Asahi Pentax, I fell completely in love with photography and with SLRs, and near the end even started doing some wedding photography and dabbling in a darkroom. Then the camera stopped working to the point where the local repair shop told me it wasn’t worth fixing. I’ll probably challenge that diagnosis in the future, but at the time I couldn’t afford a new SLR so I’ve been without a camera for too many years.

Enter the K-x. It’s just under two months old, as I bought it just before going on vacation in October. ┬áVacation was a great test run for it (and me), getting me back into the swing of things and into the love of capturing beautiful photos with an SLR.

Now that I’m going back into the daily routine of work and life, the abundance of photo opportunities that were a part of vacation aren’t likely to throw themselves at me anymore. To keep myself sharp (and to keep learning my camera), I’ll be taking part in a weekly photo challenge, through the folks at The Daily Post. This means I’ll be receiving a theme for my photo post each week, and I will have a week’s time to post my photographic interpretation of that theme.

This is the first step back toward being a perpetual tourist in my own city. My general goal is to find and record beauty, while this weekly post will be a good way to challenge myself in going beyond just recording, to set specific thematic and technical goals for myself when heading out the door with my camera.

If you want to join me on this weekly challenge, head over to The Daily Post’s photography challenges page to get the weekly theme for yourself.

See you in the viewfinder…

Pentax memory card problem & solution, part 2

Update: It worked. See here for details.

The previous solution didn’t work, after all.  I started getting “Memory card error”, “Card is not formatted”, and “Image can not be displayed” error messages again.

My new approach:

  • update my firmware (I was still running 1.00, while the new version was 1.02);
  • only connect the memory card to the computer through the camera’s USB option (as in, never plug the SD card directly into the computer)
  • only format the card in-camera;
  • never delete photos in-camera (only delete via in-camera formatting option)

 

My ‘test roll’ of 60 photos since the update has gone off without a hitch.
An interesting note: Before the firmware update, the computer didn’t see any folders or files on the SD card when the camera was connected via USB.  I’m sure it saw them sometime in the past week, so I imagine it was the memory card error that was affecting this.  Again, since the firmware update followed by formatting in-camera, this has been fixed.

 

Fingers crossed…

Pentax memory card problem & solution

While I use a K-x, this problem seems to affect more than just my camera model or brand of memory card (Kingston, class 4).

The problem(s):

  1. When trying to view the preview of my photos in-camera, some photos do not display, instead showing an “Image can not be displayed” error (or something to that effect). There was previously a “Memory Card Error” messaged displayed in the camera.
  2. When imported, these files are corrupted and do not display or import.
  3. Attempting to format the card in-camera produced the same “Memory Card Error” message.

The solution: Use your USB cable to connect the camera to the computer for importing, etc., instead of inserting the SD card into the computer directly. Then eject the camera from the computer and format the SD card through the camera’s menu.

This solved the problems listed above, for me.

Based on what various Pentax forum posters say, the mistakes that led to the problem appear to be any mix of the following: